Search - User list
Full Version: Problems I ran into installing djangoBB
Root » The Other » Problems I ran into installing djangoBB
1
ElSJaako
I was setting up a local installation for djangoBB, and I ran into some issues. Nothing too big, but they should probably be changed on http://djangobb.org/wiki/QuickInstall and/or in the package. These are things I ran into despite having some experience with virtualenv and django, I imagine people that don't have that experience would have more problems.

I'd make these changes myself, but I can't seem to register on the trac page. This is what I'd change the page to:

DjangoBB compared with 2 parts:
* DjangoBB [http://bitbucket.org/slav0nic/djangobb app]
* Djangobb [http://bitbucket.org/slav0nic/djangobb_project basic project] (example of usage for quick install)

== Installation process ==
Preinstall requiments:
* virtualenv
* setuptools or pip

Download latest source and install app:

{{{#!sh
wget https://bitbucket.org/slav0nic/djangobb/get/stable.tar.gz
tar zxvf stable.tar.gz
virtualenv .env
cd <place_for_virtualenv_dir>
source .env/bin/activate
# install requirements

# Some packages have problems on windows. On windows you should run
# easy_install pil
# easy_install postmarkup

# On all platforms, install the (other) requirements:
pip install -r extras/requirements.txt
# requirements could be missing one more requirement, so run:
pip install linaro-django-registration

# setup.py from djangobb app
./setup.py install
# ./setup.py develop will be ok too if you are planning to upgrade djangobb from hg

}}}

Download and setup basic project:

{{{#!sh
wget https://bitbucket.org/slav0nic/djangobb_project/get/tip.tar.gz
tar zxvf tip.tar.gz
cd slav0nic-djangobb_project-tip/
# this project doesn't work with the latest version of whoosh. Install an older version:
pip install whoosh==2.4
# also install everything else we need
pip install -r requirements.txt
cd basic_project/
touch local_settings.py
# At this point you need to setup the database in local_settings.py. You can use the sqlite3 example from
# https://docs.djangoproject.com/en/dev/ref/settings/#databases
./manage.py syncdb --all
./manage.py collectstatic
./manage.py runserver
}}}
slav0nic
linaro-django-pagination exists in default branch

registration exist on http://djangobb.org/register

maybe i will migrate to bitbucket from trac
ElSJaako
Thanks for updating the package. I'll try reinstalling everything with the updated version tomorrow, I'll let you know if I run into any troubles.

I tried registering for trac again, this time it gave a different error: it doesn't like my email domain.

Bitbucket might be nice, but it has the disadvantage of only allowing 5 users on a free account.
reijin
I really can't get the forum to run with the given steps (app install):
when starting the “syncdb”-command I get a KeyError “default” and
when starting the server after adding as an installed app, I get NoneType object has not attribute ‘endswith’. It refers to the models.py in Line 45 when doing the os.path.join

Any ideas?
I'm not really interested in setting up a productive forum, I just need this software to run for a securtiy example test…
slav0nic
reijin
what python version u have?
did u create local_settings file with DB settings?
reijin
slav0nic
reijinwhat python version u have?did u create local_settings file with DB settings?
thanks, but I managed to make it work.
I interpreted the part “# set DATABASE” as a comment or indicator (like: the following text has to do with setting up the Database). But in fact I had to set the DATABASE in the manage.py (if I recall correctly).

Your questions: version 2.7.X, and yes I did.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB