Search - User list
Full Version: authopenid and python2.6
Root » Bugs » authopenid and python2.6
1 2 3
scrapper
hello djangobb friends,

are you guys running djangobb and authopenid with python2.6?
i have read around the net, that it maybe would be better to run it with python2.5.

right now with django1.2.3 and python2.6.5 its not possible for me todo a login via GOOGLE, Yahoo, OpenID,...
could it really be python2.6 related?

Error-messages:
-------------------
[Mon Mar 21 08:34:45 2011] [error] openid.associate request failed: (28, 'Connection time-out')
[Mon Mar 21 08:35:00 2011] [error] Generated checkid_setup request to https://www.google.com/accounts/o8/ud using stateless mode.
[Mon Mar 21 08:35:22 2011] [error] Error attempting to use stored discovery information: <openid.consumer.consumer.TypeURIMismatch: Required type http://specs.openid.net/auth/2.0/signon not found in ['http://specs.openid.net/auth/2.0/server', 'http://openid.net/srv/ax/1.0', 'http://specs.openid.net/extensions/ui/1.0/mode/popup', 'http://specs.openid.net/extensions/ui/1.0/icon', 'http://specs.openid.net/extensions/pape/1.0'] for endpoint <openid.consumer.discover.OpenIDServiceEndpoint server_url='https://www.google.com/accounts/o8/ud' claimed_id=None local_id=None canonicalID=None used_yadis=True >>
[Mon Mar 21 08:35:22 2011] [error] Attempting discovery to verify endpoint
[Mon Mar 21 08:35:22 2011] [error] Performing discovery on https://www.google.com/accounts/o8/id?id=someid<BItObwkFuTd1nGpsnty3i4V1xrhI_L7hiD50-2w>


Thanks for your help
scrapper
scrapper
another hint:
when i try to signin via google i do get the following error-message:

The OpenID https://www.google.com/accounts/o8/id was invalid

not really an answer on the net about that issue.

greetings
sc
slav0nic
you tested it from localhost?)

for development i uses python 2.6, and this forum started at 2.6 version too
scrapper
slav0nic
you tested it from localhost?)

for development i uses python 2.6, and this forum started at 2.6 version too


i tested in production. but if its a localhost issue... than it could be nginx<->apache2 related.
i am serving static files via nginx and the rest is proxied from nginx to apache2.
maybe this is causing troubles?

i will try without nginx.

greetings
sc
scrapper
i have tested without nginx. but the problem still exists.
i am not running on localhost.

well if i find a solution i will post it here.

greetings
sc
scrapper
@slavonic

now i have tested with myopenID and its working! so it can't be that wrong.
the question is, why is google id not working?

i do use signin with goolgeID here and it works fine.

Do you know the technical differences between myopenID and google?

greetings
sc
scrapper
i think i have found the root of the problem now.
in my /account/signin/ uri there was a ?next=/forum this is making troubles.
if i remove the ?next=/forum everything works fine.

now i only have to find a solution on how to handle it without a ?next=/forum.

thank you slavonic for your time.
hope this can help someone with a similar issue.

greetings
sc

scrapper
no that was not the solution.

it only worked for some seconds.
now its not working again.

i have no idea what causes the troubles.

slav0nic
u used lates version of python-openid, authopenid and djangobb?
can u check openid url at this forum instance?
slav0nic
+ check if openid url avaibled from you hosting (is outgouning conections allowed?)
check via 'HEAD https://www.google.com/accounts/o8/id' or wget/curl/lynx etc
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB