DjangoBB

Django based forum engine

  • You are not logged in.

#1 March 23, 2011 15:21:16

slav0nic
DjangoBB Developer
From: Ukraine
Registered: 2009-10-25
Posts: 382
Reputation: +  5  -
Profile   Send e-mail  

authopenid and python2.6

plaing in console with openid module like:

from openid.fetchers import getDefaultFetcher, fetch
fetch('https://google.com/....')

maybe this will be help understand why this problem caused, olsy as i saw, python-openid used httplib2/pycurl if it installed

Offline

#2 March 24, 2011 13:46:48

scrapper
Registered: 2010-12-20
Posts: 44
Reputation: +  1  -
Profile   Send e-mail  

authopenid and python2.6

hey slav0nic :-)

finally i managed it. i tried a lot of things. debugging tcp, udp, ssh, well millions of things.
fetch('https://www.google.com/accounts/o8/id')
returned the same failure as my django-application.
Error 28 Connection timed out.

after sniffing a lot on the network-traffic, i realized that there is a lot of UDP query on the DNS domain name server. And the used domain name server was own router. I told my server to use my router as the DNS.
What normally is ok i think. The Router DNS works for all my other computers well.

But i saw the big amount of DNS queries in the UDP traffic.
Thanks to tshark sniffing software.
On ubuntu/debian in terminal type: tshark -f "udp" -i eth0 to check the UDP traffic.
first: sudo apt-get install tshark
This UDP traffic starts when you hit an OpenID provider such as google.

OK what solved my problem?
I told my server to use another DNS, not the one included in my router.
And voila now everything works fine.

Hope no other pure guy will get such a damned failure, because it was hard to find, as the DNS is working quite well.
So i changed the DNS from my router to the DNS offered by the internet provider.
And everything is working as expected now! OpenID rocks! :-)

Thank you slav0nic for your time.
You helped me a lot!

Best greetings
scrapper

Edited scrapper (March 24, 2011 13:52:25)

Offline

#3 Aug. 18, 2017 07:24:28

maryhaugen
Registered: 2017-08-18
Posts: 4
Reputation: +  0  -
Profile   Send e-mail  

authopenid and python2.6

Did you test in dashboard?

Offline

#4 Aug. 27, 2018 21:02:11

ArchieMeell
Registered: 2018-07-21
Posts: 85
Reputation: +  0  -
Profile   Send e-mail  

authopenid and python2.6

Offline

#5 Aug. 29, 2018 20:39:04

ArchieMeell
Registered: 2018-07-21
Posts: 85
Reputation: +  0  -
Profile   Send e-mail  

authopenid and python2.6

Offline

#6 Aug. 30, 2018 22:39:00

ArchieMeell
Registered: 2018-07-21
Posts: 85
Reputation: +  0  -
Profile   Send e-mail  

authopenid and python2.6

Offline

#7 Sept. 1, 2018 14:21:17

ArchieMeell
Registered: 2018-07-21
Posts: 85
Reputation: +  0  -
Profile   Send e-mail  

authopenid and python2.6

Offline

#8 Sept. 4, 2018 02:55:44

ArchieMeell
Registered: 2018-07-21
Posts: 85
Reputation: +  0  -
Profile   Send e-mail  

authopenid and python2.6

Offline

#9 Sept. 19, 2018 20:05:49

Larrydic
Registered: 2018-09-19
Posts: 4
Reputation: +  0  -
Profile   Send e-mail  

authopenid and python2.6

Offline

Board footer

Moderator control

Powered by DjangoBB

Lo-Fi Version